The incident has been resolved. We are in ongoing discussions with our infrastructure provider regarding the cause of this issue. We apologise for the inconvenience caused.
Posted Jun 30, 2026 - 14:13 CEST
Monitoring
The issue with our infrastructure provider appears to have been resolved. We're monitoring the situation.
Posted Jun 30, 2026 - 14:02 CEST
Investigating
We're currently experiencing a major outage affecting core services. Our team is working urgently to resolve the issue.
Please do not contact our support team for updates. We will post updates regarding the status of the incident here. You can also subscribe to status updates at the top of this page.
Posted Jun 30, 2026 - 13:43 CEST
This incident affected: Nuki Website & Online Shop.